wijzig taal:

Wie in Excel wel eens met de functie VERT.ZOEKEN (verticaal zoeken) gewerkt heeft, zal waarschijnlijk weten dat hiermee alleen waarden rechts van de zoekkolom te vinden zijn. Stel een Excel-sheet bevat de volgende gegevens:

links verticaal zoeken

Wanneer nu bijvoorbeeld het rekeningnummer van iemand opgezocht moet worden, dan kan dat prima met de functie VERT.ZOEKEN. Als je bijvoorbeeld in bovenstaand voorbeeld in cel B10 een naam ingeeft, dan verschijnt in cel C10 automatisch het rekeningnummer als je in cel C10 de volgende formule ingeeft:

=VERT.ZOEKEN(B10;A2:C7;3;ONWAAR)

Deze functie werkt als volgt: de ingegeven zoekwaarde in cel B10 wordt opgezocht in de eerste kolom van de matrix A2:C7, waarna de waarde uit de 3e kolom (is het rekeningnummer) van deze matrix wordt weergegeven. Het benaderen is ingesteld als ONWAAR, wat wil zeggen dat de functie alleen een resultaat geeft als de gevonden waarde in de eerste kolom van de matrix exact gelijk is aan de zoekwaarde.

Maar wat nu als je in bovenstaand overzicht het rekeningnummer in wilt geven en de bijbehorende naam wilt zoeken. Dit kan niet met VERT.ZOEKEN, omdat de gevonden waarde links van de zoekkolom staat. Eventueel kan wel gebruik worden gemaakt van een hulpkolom, maar het gebruik van een hulpkolom moet zoveel mogelijk vermeden worden. Een alternatief is om de volgende functie in te geven in cel C10:

=INDEX(A2:A7;VERGELIJKEN(B10;C2:C7;0))

Deze functie zorgt ervoor dat met de VERGELIJKEN de positie van de exacte zoekwaarde in de zoekkolom (C2:C7) gevonden wordt, waarna met behulp van de functie INDEX de waarde van dezelfde positie uit kolom A2:A7 wordt weergegeven. Op deze manier is het dus mogelijk om ook verticaal te zoeken links van de zoekkolom.

Excel Office 365

In Excel voor Office 365 kan hiervoor ook de formule X.ZOEKEN gebruikt worden. Of deze functie beschikbaar is, is afhankelijk van het type abonnement. De formule wordt dan:

=X.ZOEKEN(B10;C2:C7;A2:A7)
Plaats reactie
Door het plaatsen van een commentaar verklaart u bekend te zijn en akkoord te gaan met de privacy verklaring van worksheetsvba.com.


arrow_up