wijzig taal:

Het uitfilteren van unieke waarden uit een kolom met gegevens kan in Excel bijvoorbeeld met matrixformules. Stel een kolom in Excel bevat onderstaande gegevens:

unieke waarden weergeven 1

Om nu in kolom B de unieke waarden van de gegevens van kolom A weer te geven, kan gebruik worden gemaakt van de volgende matrixformule in cel B2:

=ALS.FOUT(INDEX(A$2:A$15;VERGELIJKEN(ONWAAR;ISGETAL(VERGELIJKEN(A$2:A$15;$B$1:B1;0));0));"")

Dit is een matrixformule en moet daarom bij het ingeven afgesloten worden met CTRL+SHIFT+ENTER. Daarna verschijnen automatisch accolades om de formule, ten teken dat het om een matrixformule gaat. De formule kan daarna naar beneden gekopieerd worden. Daarna ontstaat het volgende overzicht:

unieke waarden weergeven 2

Te zien is dat in kolom B alleen de unieke waarden uit kolom A worden weergegeven.

Korte uitleg

Het gaat om een geneste matrixfunctie waarvan de werking in woorden lastig is uit te leggen. Het komt er in het kort op neer dat de laatste VERGELIJKEN-functie zoekt naar waarden van de bronkolom in de bovenliggende rijen. De eerste VERGELIJKEN-functie zoekt naar de eerste positie, waarop de laatste VERGELIJKEN-functie niets kan vinden en dus ISGETAL onwaar wordt. Vervolgens wordt met de INDEX-functie de waarde van deze positie weergegeven. Als de INDEX-functie een foutmelding geeft omdat alle waarden al gevonden zijn, dan wordt een lege cel weergegeven.

Excel Office 365

In Excel voor Office 365 hoeven normaal gesproken matrix formules niet met CTRL+SHIFT+ENTER afgesloten te worden, maar het mag wel. Daarnaast kan in deze versie de functie UNIEK beschikbaar zijn. Dit is afhankelijk van het type abonnement. Als deze functie beschikbaar is dan kun je in plaats van bovenstaande redelijk complexe matrixformule volstaan met de volgende formule:

=UNIEK(A2:A15)

Unieke waarden weergeven met draaitabel

Ook kan een draaitabel gebruikt worden om unieke waarden weer te geven. Selecteer hiervoor de gegevens in A2:A15 en kies voor invoegen draaitabel. Sleep daarna bij Draaitabelvelden het veld naar RIJEN. Daarna worden de unieke waarden alfabetisch weergegeven met mogelijkheid om dit te filteren. De weergave van het Eindotaal in de draaitabel kan met rechtsklik verwijderd worden. Een nadeel van de draaitabel is dat deze niet automatisch aangepast wordt als de waarden in A2:A15 wijzigen. Dat kan met een macro dan wel weer opgevangen worden, maar dat blijft hier even buiten beschouwing.

Vragen / suggesties

Hopelijk heeft dit artikel geholpen om unieke waarden weer te geven in Excel. Als er verdere vragen over dit onderwerp zijn of suggesties voor verbetering, plaats dan een reactie hieronder.

Reacties  
# Ramon 07-11-2020 11:31
Deze formule heeft me enorm verder geholpen! Dank daarvoor. Is er ook de mogelijkheid om in kolom C toe te voegen het aantal keer dat een unieke waarde voorkomt? In jouw voorbeeld Jan 5x
Antwoorden
# Manfed van den Noort 07-11-2020 14:46
Dat kan met de formule AANTAL.ALS.
Dus in dit geval =AANTAL.ALS(A$2:A$15;B2)
Antwoorden
arrow_up