wijzig taal:

Het uitfilteren van unieke waarden uit een kolom met gegevens kan in Excel bijvoorbeeld met matrixformules. Stel een kolom in Excel bevat onderstaande gegevens:

unieke waarden weergeven 1

Om nu in kolom B de unieke waarden van de gegevens van kolom A weer te geven, kan gebruik worden gemaakt van de volgende matrixformule in cel B2:

=ALS.FOUT(INDEX(A$2:A$15;VERGELIJKEN(ONWAAR;ISGETAL(VERGELIJKEN(A$2:A$15;$B$1:B1;0));0));"")

Dit is een matrixformule en moet daarom bij het ingeven afgesloten worden met CTRL+SHIFT+ENTER. Daarna verschijnen automatisch accolades om de formule, ten teken dat het om een matrixformule gaat. De formule kan daarna naar beneden gekopieerd worden. Daarna ontstaat het volgende overzicht:

unieke waarden weergeven 2

Te zien is dat in kolom B alleen de unieke waarden uit kolom A worden weergegeven.

Korte uitleg

Het gaat om een geneste matrixfunctie waarvan de werking in woorden lastig is uit te leggen. Het komt er in het kort op neer dat de laatste VERGELIJKEN-functie zoekt naar waarden van de bronkolom in de bovenliggende rijen. De eerste VERGELIJKEN-functie zoekt naar de eerste positie, waarop de laatste VERGELIJKEN-functie niets kan vinden en dus ISGETAL onwaar wordt. Vervolgens wordt met de INDEX-functie de waarde van deze positie weergegeven. Als de INDEX-functie een foutmelding geeft omdat alle waarden al gevonden zijn, dan wordt een lege cel weergegeven.

Excel Office 365

In Excel voor Office 365 hoeven normaal gesproken matrix formules niet met CTRL+SHIFT+ENTER afgesloten te worden, maar het mag wel. Daarnaast kan in deze versie de functie UNIEK beschikbaar zijn. Dit is afhankelijk van het type abonnement. Als deze functie beschikbaar is dan kun je in plaats van bovenstaande redelijk complexe matrixformule volstaan met de volgende formule:

=UNIEK(A2:A15)
Plaats reactie
Door het plaatsen van een commentaar verklaart u bekend te zijn en akkoord te gaan met de privacy verklaring van worksheetsvba.com.


arrow_up